Triple M Register
Triple M Register
Home | My Files | Policies | Profile | Register for the forum | Active Topics | Subscribers | Search | Locate Subscribers | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Triple-M Register Forums
 Technical Information Forum
 J2 front & side valance mounting
 Forum Locked  Topic Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

John Libbert

USA
120 Posts

Posted - 24/07/2018 :  00:26:39  Show Profile
Hi folks,

Is there any type of padding such as felt or rubber strip that goes between the top of the chassis rails and the front and side valances on a cycle wing J2? I ask as there are five holes, 3/16" diameter on the top of both chassis rails approximately 7 1/4" apart starting near the front dumb iron. Where do the side valances attach to the chassis other than the bracket that's attached to the chassis just in front of the tub? There must be something that holds the valance to the chassis so the bonnet latch doesn't just lift up the valance from the chassis.

Besides the front cross bar clamp and threaded bolt with the octagonal head with MG logo, is there anything else that holds the front valance on?

At the other end of the chassis, under the petrol tank, I believe there are rubber pieces on the top of the chassis and are held in place with bifurcated rivets. Are there just two holes 3/16" diameter on each side for this rubber piece?

Thanks,

John

Greensa

United Kingdom
85 Posts

Posted - 24/07/2018 :  10:56:53  Show Profile
John,
I think my lengthy reply to your post about multiple holes in your chassis is worth reviewing. My ‘original’ valances had some padding strip on top of the chassis rail...I have replaced this with thin rubber strip. The valances have a fastener at the front edge which is hidden under the rear edge of the apron, then a single fixing about half way between the two wing struts just above the brake cable mount and finally the two which attach to the bracket. ( my original had more fixings along the chassis rail so others may know what is correct).

The apron has no fixings along the chassis rails and is fixed st the rear by the side valances slotting into the groove on the underside of the apron

I am away so can’t check but I think there were three rivet holes either side to hold the rubber strip ( which incidentally was too thick when I came to mount the new fuel tank so I replaced ithem with a thinner rubber strip). Hope that helps..., regards,





SteveG
J2760
Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked  Topic Locked
 Printer Friendly
Jump To:
Triple M Register © 2003-2019 MGCC Go To Top Of Page
This page was generated in 0.11 seconds. Snitz Forums 2000